Skip to main content
 首页 » 编程设计

linux之Subclipse 无法加载默认的 SVN 客户端,即使一切都已正确安装

2023年11月14日32softidea

我在使用 Subclipse 时遇到问题,当我第一次尝试执行诸如提交、更新或查看历史记录之类的操作时没有任何反应,而我第二次尝试时出现此错误:

所有这一切过去都工作得很好,但突然就停止工作了。所有必需的包都已安装:

首选项中的“SVN 界面”选项为空/变灰:

我有另一个 Eclipse 安装 (Java EE),它安装了相同的包,一切仍然正常。

我已经尝试重新安装所有 SVN 软件包,但无济于事。我在 Linux Mint 16 Petra 上运行 Eclipse Kepler,SVN 版本为 1.7.9。

如有任何帮助,我们将不胜感激。

编辑:我发现其他 Eclipse 安装有不同(旧)版本的插件。更新这些后,该安装也停止工作。我怀疑我的 SVN 版本 (1.7.9) 太旧了。我看到 1.8.x 已经发布,如何在我的 Linux 安装中安装该版本?运行 apt-get update/upgrade 不会这样做。我看到有人在谈论运行 dist-upgrade,但过去曾破坏过一些东西,所以除非绝对必要,否则我非常不愿意这样做。

编辑:我设法使用 these 安装了 subversion 1.8.10|步,但无济于事。

请您参考如下方法:

我设法解决了我删除 SVNKit 并改为安装“Subversion JavaHL Native Library Adapter”的问题。我之前尝试过,但在我也将 subversion 更新到 1.8 后它确实有效。